If you get this message when trying to update some packages :

Requires Installation of Untrusted Packages
This requires installing packages from unauthenticated sources.

Try this line:

sudo apt-get update && sudo apt-get dist-upgrade