You may face this error during the installation of Passenger:

Error: Package: mod_passenger-5.0.26-8.el6.x86_64 (passenger)
Requires: httpd-mmn = 20051115

Do the following:

locate yum.conf

Then remove httpd* from this line:

exclude=apache* bind-chroot courier* dovecot* exim* filesystem httpd* mod_ssl* mydns* mysql* nsd* perl* php* proftpd* pure-ftpd* ruby* spamassassin* squirrelmail*

Save and close yum.conf. Install passenger again:

sudo yum install -y epel-release pygpgme curl
sudo curl --fail -sSLo /etc/yum.repos.d/passenger.repo https://oss-binaries.phusionpassenger.com/yum/definitions/el-passenger.repo
# Install Passenger + Apache module
 sudo yum install -y mod_passenger